KUSONEKOの見る世界

IOS-XE 備忘録

※注意!私の調査結果に基づく内容なので間違っている場合があります

ISR4000 設定関連

Port-Channel + Bridge Domain + HSRP 設定例

IOS-XEでは、BVIが使えなくなり、代わりにBDIという機能がある。
インターフェースを論理的に分けるため、 service instanceを設定する。
service instanceは、ip addressが入力されているインターフェースには設定できない。
service instanceは、サブインターフェースに設定できない。
ISR4kは、L3 Port-channelのみ使用でき、オンボードのインターフェースのみをMemberとすることができる。
bridge-domain 100
bridge-domain 200
!
interface Port-Channel1
 no ip address
 service instance 100 ethernet
  encapsulation untagged
  bridge-domain 100
 !
 service instance 200 ethernet
  encapsulation dot1q 200
  rewrite ingress tag pop 1 symmetric
  bridge-domain 200
 !
interface GigabitEthernet0/0/1
 no ip address
 channel-group 1
!
interface GigabitEthernet0/0/2
 no ip address
 channel-group 1
!
interface BDI100
 ip address 192.168.255.1 255.255.255.252
!
interface BDI200
 ip address 192.168.0.252 255.255.255.0
 standby 1 ip 192.168.0.254

Catalyst 3850/3650

ポートチャネルのロードバランスで使用するポートを調べる方法

switch# show platform software fed etherchannel [ switch switch-number ] channel-group-number { group-mask | load-balance mac src-mac dst-mac [ ip src-ip dst-ip [ port src-port dst-port ] ] }

バージョンアップ・ダウン関連

Catalyst3850/3650(インストールモード)

TFTPよりFTPの方がダウンロードが断然速い。FTPが使えない環境ならTFTPで気長に待つ。

3.xE → 16.x.x or 16.6.x

Switch# copy tftp://x.x.x.x/cat3k_caa-universalk9.16.xx.xx.SPA.bin flash:cat3k_caa-universalk9.16.xx.xx.SPA.bin
Switch# software install file flash:cat3k_caa-universalk9.16.xx.xx.SPA.bin new force
Do you want to proceed with reload? [yes/no]: yes
Switch# delete flash:cat3k_caa-universalk9.16.xx.xx.SPA.bin

16.6.x → 16.x.x

Switch# copy tftp://x.x.x.x/cat3k_caa-universalk9.SPA.03.xx.xx.E.xxx-xx.xx.bin flash:cat3k_caa-universalk9.SPA.03.xx.xx.E.xxx-xx.xx.bin
Switch# request platform software package install switch all file flash:cat3k_caa-universalk9.SPA.03.xx.xx.E.xxx-xx.xx.bin
Switch# reload
Switch# request platform software package clean switch all file flash:

16.x.x → 3.xE

Switch# copy tftp://x.x.x.x/cat3k_caa-universalk9.16.xx.xx.SPA.bin flash:cat3k_caa-universalk9.16.xx.xx.SPA.bin
Switch# request platform software package install switch all file flash:cat3k_caa-universalk9.16.xx.xx.SPA.bin
Switch# reload
Switch# software clean file flash:

Catalyst3850/3650(バンドルモード→インストールモード)

3.xE → 16.x.x or 16.6.x

Switch# copy tftp://x.x.x.x/cat3k_caa-universalk9.SPA.03.xx.xx.E.xxx-xx.xx.bin flash:cat3k_caa-universalk9.SPA.03.xx.xx.E.xxx-xx.xx.bin
Switch# software expand file flash:cat3k_caa-universalk9.SPA.03.xx.xx.E.xxx-xx.xx.bin
 or
Switch# software expand running to flash:

Switch# configure terminal
Switch(config)# boot system flash:packages.conf
Switch(config)# end
Switch# write memory
Switch# reload
Switch# write erase
Switch# software clean file flash:
Switch# copy tftp://x.x.x.x/cat3k_caa-universalk9.16.xx.xx.SPA.bin flash:cat3k_caa-universalk9.16.xx.xx.SPA.bin
Switch# software install file flash:cat3k_caa-universalk9.16.xx.xx.SPA.bin new force
Do you want to proceed with reload? [yes/no]: yes
Switch# request platform software package clean switch all file flash:

16.x.x → 16.x.x

Switch# copy tftp://x.x.x.x/cat3k_caa-universalk9.16.xx.xx.SPA.bin flash:cat3k_caa-universalk9.16.xx.xx.SPA.bin
Switch# request platform software package expand file flash:cat3k_caa-universalk9.16.xx.xx.SPA.bin
Switch# configure terminal
Switch(config)# boot system flash:packages.conf
Switch(config)# end
Switch# write memory
Switch# reload
Switch# request platform software package clean switch all file flash:

ISR4000

3.xE → ?

Router# copy tftp://x.x.x.x/isr4400-universalk9.03.10.00.S.xxx-x.S-ext.SPA.bin flash:isr4400-universalk9.03.10.00.S.xxx-x.S-ext.SPA.bin
Router# delete oldfile.bin
Router# reload